Error - "Unable to obtain or validate Voyant license", Java (JRE) 1.7.0_25_b17

Description: Following an update to Java (JRE) JRE 1.7.0_25_b17, some users have reported that the software shows the error "unable to validate licence" and are unable to access client cases. The software launches without issue and the user can log in but the error appears after login or if launching from the website, the error appears after the software launches. 

In at least one case, the error did not appear but the user was shown a blank center screen, as if there was a missing interstitial window - e.g. the trial countdown, build notes, or upcoming training announcements. The software wrapper and the left navigation links are shown but cannot be clicked. 

Issue: Although we don't know the cause, it seems that in some instances, certainly not all, upgrading to JRE 1.7.0_25_b17 is botching Voyant. 

----------------------------

IMPORTANT NOTE: 

There are two errors that have very similar wording but very different causes.  

"Unable to obtain license", which seems to be caused by the update to JRE 7 version 25.

"Invalid license", which is usually caused by the date being set incorrectly on the computer, especially when the computer is back dated.

Support: Please make note of this if you get similar tickets. Pay close attention to the wording of the error and maybe as a precaution always have a quick look at the date on the computer before doing anything more complicated.

--------------------------

Resolution

If someone  reports the error "unable to obtain license": 

1. First try the usual. Have the user attempt to launch the software from the browser. Sign into the website and click Plan Now. 

2. If the error persists, try uninstalling and reinstalling Java. This final step seems to resolve the problem. 

NOTE: You may need to revert from the current release JRE 1.7.0_25 to the previous one, JRE 1.7.0_21. Earlier releases of Java can be obtained here -

http://www.oracle.com/technetwork/java/archive-139210.html

You may need an Oracle login to download the archived version. 

Another more convenient source for version 22 is www.oldapps.com/java.php?old_java=12124?download