Installation, Java Error - "Failed to validate certificate. The application will not be executed"

Issue: User gets the following error when trying to launch Voyant, 

"Failed to validate certificate. The application will not be executed.

This error reoccurs, with each repeated attempt to install the software, and the user is left unable to complete the installation.

NB: We have found, in some instances, that this error is the result of an incorrect date/time setting, on the machine itself - when the current date/time on the machine is significantly incorrect, the software will be unable to confirm that the user has a valid, current license. Consequently, therefore, the first thing we recommend is to double-check that the date/time setting, on the machine, is correct.

 

Cause:
Voyant only requires that Java 6 Update 14 or later; however, ideally, users should be running the latest release of Java available from http://java.com.

This error has appeared when users were running older releases of Java - e.g. JRE 1.6.0_18. Although compatible with our software, the release of Java was itself the issue. The issue was with the version of Java and its handling of certificates in general (not our application). However, the error has appeared with some more recent releases of Java e.g. Java 8 Update 77.

Solutions:

We have two different, possible solutions for this issue - we recommend trying the first option, a simple Java settings change, before trying the second, which involves uninstalling and reinstalling Java:

 

Option 1:

To correct this on a PC: 
1.  Open the Java Control Panel:  Start > Control Panel > Programs > Java 
2.  Go to the Advanced tab > Security > General 
3.  UNCHECK the option:  "Enable online certificate validation" 
4.  CHECK the option:  "Enable list of trusted publishers" 

To correct this on a MAC: 
1.  Go to /Applications/Utilities/Java Preferences 
2.  Go to the Advanced tab > Security section 
3.  UNCHECK the option:  "Enable online certificate validation" 
4.  CHECK the option:  "Enable list of trusted publishers" 

The next time you launch Voyant Java may prompt you with "certification failed the validation" message and give you the option to trust it anyway. 

Select the option to indicate that you trust it, and it should be fine from then on.

 

Option 2:

Uninstall Java (the JRE) and install the latest release from http://java.com to resolve the issue.

Unfortunately, simply updating to the latest release of Java does not resolve matters, in our past experience at least, since the older release would remain on the computer. Java updates do not necessarily replace earlier installations. A full deinstallation of Java is required.

Once Java has been uninstalled and the latest version installed, download Voyant by signing into the appropriate website and clicking the Adviser button. 

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  Canada - canada.planwithvoyant.com

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  Ireland - www.planwithvoyant.ie

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  United Kingdom - www.planwithvoyant.co.uk

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  United States - www.planwithvoyant.com

 

There is no need to be concerned about losing your personal settings for Voyant e.g. market assumptions, model portfolios, other preferences). Even when uninstalling Java, your personal settings will remain in place and will not be lost because they are not stored in Java; rather they are stored locally in your user profile. 

 

Related topics: 

Installing Voyant - How to install Voyant and begin your first client case